Degraded performance of South-JKT
Incident Report for IDCloudHost
Resolved
This incident has been resolved.
Posted Mar 19, 2024 - 12:24 WIB
Identified
Our team discover an issue and in a process to fix it.
Posted Mar 19, 2024 - 12:22 WIB
Investigating
We are currently investigating this issue.
Posted Mar 19, 2024 - 11:51 WIB
This incident affected: Cloud VPS Console (Jakarta South).